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	The Roughouse Hotel

Some notes on complex spreadsheet features.



The spreadsheet required for this project does not have to be particularly advanced. However, in order to comply with the assessment criteria for this unit, the spreadsheet needs to include at least SIX of the following “more complex features”… 
(1) 
lists and tables – sorting, lookup tables, subtotals and totals

(2) 
list boxes and drop-down boxes to select data for entry

(3) 
styles to create a customised cell format

(4) 
named cells and ranges for use in formulae

(5) 
auto-fill lists, for lists of dates or days of the week

(6) 
validation – restricting data input to acceptable data values

(7) 
templates – creating standard spreadsheet layouts for repeated use

(8) 
protecting cells by hiding and locking cells

(9) 
sort, to sort single and multiple columns of data

(10) 
control buttons, to initiate macros

(11) 
multiple sheets with links between them

(12)
multiple views or windows.

Worksheet protection, hiding and locking cells. 
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	The first feature to look at is present on most of the worksheets in the file. Each sheet is “protected” in order to prevent users from changing things they are not wanted to. 

Worksheet protection can be turned off and on by using the “Tools” menu and selecting “Protection”, then “Unprotect Sheet…”. 




	Protection can be switched back on in the same manner, Microsoft Excel will then prompt for the choices shown opposite. 

For your convenience, no password has been set on the protection of this worksheet. 
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Before you will be able to view any of the advanced features or formulae in this spreadsheet, you will have to turn off the protection on each of the worksheets individually. 
In order to “lock” or “unlock” individual cells (lock = prevents users from altering the cells and unlock = “frees cells for changing by the user), the cell/s must be locked or unlocked, before protection is enabled. 
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	Cells formatted as “locked” will only be fully protected from being changed by users, if worksheet protection has been enabled in addition to cells being “locked” using the “Format” menu, then choosing “Cells…”



	From the box which now appears, select the [Protection] tab. 

Locked cells do not allow users to change their contents. 

Hidden cells cannot be sen by users. 

To meet all assessment criteria, locked and hidden cells should be used within the spreadsheet project. 
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	Lastly, when enabling worksheet protection after cells have been locked or hidden. A number of further options are available. 

It is possible to mark cells so that those which have been locked, cannot even be selected (clicked on), in order to view their contents.
This feature has been used in the main menu of the Roughouse Hotel spreadsheet, so that users can only select (click on), the buttons which launch the different sections of the spreadsheet. 


Control buttons to initiate macros 
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	First, you need a “Macro”. 

The macro this example creates, prints the single invoice page. 

Select the “Tools” menu, followed by “Macro…”, then “Record New Macro…”


	In the box which appears, give the macro an appropriate name. 

Note: Macro names cannot contain spaces or certain symbols. Stick to text and numbers only.
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	A new toolbar appears on the page. The macro recording programme is now recording every key press and mouse-click you make, in order to “play them back”, when you run the macro.

When you have finished, you will need to click on the blue, square, “Stop” button. 
Next, you record the macro…


	For this example, select the “File” menu, then “Print…”
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	In the “Print” dialogue box, select “Page(s)”, “From: [1] To: [1]”. This will print the first page of the invoice only. Then click on the [OK] button to print. 

This is all that is required, stop recording the macro now…
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	The next stage is to create a button to which the macro can be assigned. 

This is called a “command button” – because the button has a command assigned to it, the command in this case will be the macro that has just been created. 

In order to do this, we need to have access to a “toolbar” which we do not usually see. To view this toolbar, we need to select the “View” menu, followed by “Toolbars” and the “Control Toolbox”. 

The following toolbar then appears…
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From this toolbar, select the rectangular “Command Button” icon, as shown above. 
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	Clicking anywhere on the spreadsheet, will now create a command button. 

Right-click the command button and select “CommandButton Object”, then “Edit”…
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	This will allow you to provide a caption for the button. 

Right-clicking the button itself, will allow you to choose more options, by selecting the “Properties” item…
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	From the options which then appear, you can make a large number of selections, including font formatting, as illustrated opposite.


	The next stage is to assign the macro “programming code” to the button.

Right-click the button and select “View Code”. 
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The following screen allows programming code to be assigned to the button…
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	From this screen, choose the “Tools” menu, then “Macros…”


	A list of all the macros available will now appear. Select the macro created earlier and click on the [Edit] button. 
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The next screen shows the macro programming code for the macro we created earlier…
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	Highlight and copy only the lines of code that run the macro. 

This is illustrated in the following screenshot.


	From the screenshot opposite, we can see that the only text we need is located between the two “Sub” statements. 
The text in green is just describing the macro, this can be copied or not. 

Once you have copied the text, you can close this code window… 
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Back in the window for viewing the control button’s code, we can paste the programming code between the two “Sub” statements – this is why we did not the “Sub” statements from the previous window, because there were already two here. 
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The screen below shows the completed code for the control button. 
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	Before closing the code window, click on the “Save” icon to save the changes you have made. 

Then click on the [Close] button to exit the code window. 
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Note the formula displayed when the control button is selected. 
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	Now save the spreadsheet and exit. When you next open the spreadsheet and click on the [Print Invoice] button, the macro will be triggered and the single page invoice will be printed.
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Nested “IF” statements, with links between multiple sheets. 
The “Roughouse Hotel” example spreadsheet contains the six complex features highlighted in bold in the introduction (above), plus a number of others, including “nested ‘IF’ formulae” in the hotel’s “Invoice” sheet. 
These look to see if a cell has a specific value in it, if it does, then they show a value in another cell, and if it doesn’t, then they show a statement like “Room does not exist.”

Study these carefully and UNDERSTAND what they are doing, I know they look complicated, but they are not really, they just repeat a pattern over and over. 

For example, on the “Invoice” sheet, cell C10 checks for a numerical value in cell B10, it uses the following formula…

=IF($B$10=1,'Room Details'!D$2,(IF($B$10=2,'Room Details'!D$3,(IF($B$10=3,'Room Details'!D$4,(IF($B$10=4,'Room Details'!D$5,(IF($B$10=5,'Room Details'!D$6,(IF($B$10=6,'Room Details'!D$7,"Room does not exist")))))))))))

If the numerical value of “1” exists in cell B10, then the cell shows the value contained in cell D2 in the Room Details sheet. If the numerical value of “2” exists in cell B10, then the cell shows the value contained in cell D3 in the Room Details sheet, and so on until the numerical value of “6” is reached. Any value other than 1 to 6 (inclusive) is shown in cell B10, then the message “Room does not exist” will be displayed. 

Create a drop-down list from a range of cells
This final section has been taken directly from the Microsoft web site, at the following URL…

http://office.microsoft.com/en-gb/assistance/HP052022151033.aspx
	To make data entry easier, or to limit entries to certain items that you define, you can create a drop-down list of valid entries that is compiled from cells elsewhere on the worksheet. When you create a drop-down list for a cell, it displays an arrow next to that cell. To enter information in that cell, click the arrow, and then click the entry that you want.
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To create a drop-down list from a range of cells, use the Validation command under the Data menu.

To create a list of valid entries for the drop-down list, type the entries in a single column or row without blank cells. For example: 

	
	A

	1
	Sales

	2
	Finance

	3
	R&D

	4
	MIS


Note You may want to sort the data in the order that you want it to appear in the drop-down list.

If you want to use another worksheet or another workbook, do one of the following: 

Use a different worksheet in the same workbook  Type the list on that worksheet, and then define a name (name: A word or string of characters that represents a cell, range of cells, formula, or constant value. Use easy-to-understand names, such as Products, to refer to hard to understand ranges, such as Sales! C20:C30.) for the list.


How?

Select the cell, range of cells, or nonadjacent selections (nonadjacent selection: A selection of two or more cells or ranges that don't touch each other. When plotting nonadjacent selections in a chart, make sure that the combined selections form a rectangular shape.) that you want to name. 

Click the Name box at the left end of the formula bar (formula bar: A bar at the top of the Excel window that you use to enter or edit values or formulas in cells or charts. Displays the constant value or formula stored in the active cell.). 
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Name box

Type the name for the cells, for example, ValidDepts. 

Press ENTER. 

Note You cannot name a cell while you are changing the contents of the cell.

Use a different worksheet in a different workbook Type the list on that worksheet, and then define a name with an external reference to the list. 

How?

Open the workbook that contains the list of drop-down entries. 

Open the workbook where you want to validate cells, point to Name on the Insert menu, and then click Define. 

In the Names in workbook box, type the name, for example, ValidDepts. 

Accept the default value in the Refers to: box, and then click OK. 

In the Refers to box, delete the contents, and keep the insertion pointer in the box. 

On the Window menu, click the name of the workbook that contains the list of drop-down entries, and then click the worksheet that contains the list. 

Select the cells containing the list. 

In the Define Name dialog box, click Add, and then click Close. 

Notes 

If several users need to open the workbook simultaneously, set the workbook to read-only recommended when you save it. For more information, see Prompt to open a file as read-only. 

The workbook must be open for users to use the validation list. You can record a macro to open it automatically whenever the workbook with the data validation is opened. For more information about creating and using macros, see About macros in Excel.

Select the cell where you want the drop-down list. 

On the Data menu, click Validation, and then click the Settings tab. 

In the Allow box, click List. 

To specify the location of the list of valid entries, do one of the following: 

If the list is in the current worksheet, enter a reference to your list in the Source box. 

If the list is on a different worksheet in the same workbook or a different workbook, enter the name that you defined for your list in the Source box.

In both cases, make sure that the reference or name is preceded with an equal sign (=). For example, enter =ValidDepts. 

Make sure that the In-cell drop-down check box is selected. 

To specify whether the cell can be left blank, select or clear the Ignore blank check box. 

Optionally, display an input message when the cell is clicked.

How?

Click the Input Message tab. 

Make sure that the Show input message when cell is selected check box is selected. 

Type the title and text for the message (up to 225 characters).

Specify how you want Microsoft Office Excel to respond when invalid data is entered.

How?

Click the Error Alert tab, and make sure that the Show error alert after invalid data is entered check box is selected. 

Select one of the following options for the Style box: 

To display an information message that does not prevent entry of invalid data, click Information. 

To display a warning message that does not prevent entry of invalid data, click Warning. 

To prevent entry of invalid data, click Stop.

Type the title and text for the message (up to 225 characters). 

Note If you don't enter a title or text, the title defaults to "Microsoft Excel" and the message to: "The value you entered is not valid. A user has restricted values that can be entered into this cell."

Notes 

The width of the drop-down list is determined by the width of the cell that has the data validation. You may need to adjust the width of that cell to prevent truncating the width of valid entries that are wider than the width of the drop-down list. 

The maximum number of entries that you can have in a drop-down list is 32,767. 

If the validation list is on another worksheet in the same workbook or another workbook and you want to prevent users from seeing it or making changes, consider hiding and protecting that worksheet. For more information, see Display or hide a workbook or sheet and Overview of security and protection in Excel. 
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